Back to overview
Degraded

Microsoft Azure issue

Oct 29 at 05:18pm CET
Affected services
HUB

Resolved
Oct 29 at 09:54pm CET

HUB is working again. Certain features still have limited performance but functional.

Updated
Oct 29 at 08:38pm CET

Microsoft expect full recovery of the services by 23:20 UTC on 29 October 2025. We will provide another update on our progress within two hours, or sooner if warranted.

Updated
Oct 29 at 07:54pm CET

According to Microsoft, they where able to identify the issue and we are expecting a recovery of our services within the next 1,5 hours.

Created
Oct 29 at 05:18pm CET

We are currently experiencing issues with Microsoft Azure that are affecting the availability of HUB. Our team is actively monitoring the situation and working closely with Microsoft to ensure service is restored as soon as possible.